Saturday, October 26, 2013

Laptop keyboard stopped working after upgrade to Lubuntu 13.10...fixed

I have a fairly old LG laptop (circa 2007) that I have been running Lubuntu on. It is a lighter-weight version of Ubuntu, that uses the LXDE desktop rather than Gnome. Performance is reasonable with it. Anyway, since this is sort of the guinea-pig of all my systems, I thought I'd upgrade it to the latest version of Lubuntu (my other systems are still on the 12.04 LTS releases).

The upgrade went pretty smoothly, it has to be said. It was only when I got to the login screen and tried to type my password that things went wrong - I couldn't type anything. None of the keys worked, not even Control or F1, so I could switch to a text console. The touchpad and left/right click buttons were still working, and the keyboard still worked in the Grub boot menu.

A bit of head scratching, and plugging in a separate USB keyboard allowed me to type again. But that isn't quite an optimal solution. A bit of Googling led me to the following bug report for someone else with an LG laptop. Going by the eighth comment in that, it turns out a couple of options have to be added to the grub menu, by editing the /etc/default/grub file. In my case, the file had the following line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

I added two options to the end, so it became:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nopnp=1 i8042.dumbkbd=1"

Saved the file, and ran sudo update-grub to let the changes apply, and rebooted. I am now typing this blog post on the working laptop keyboard!

12 comments:

  1. Thanks for posting this fix! This was exactly what I was looking for - I've got an old LG T1.

    ReplyDelete
  2. Some keys of my laptop stopped working. I thought my laptop won't work properly anymore, so I consulted one of my friends for advice. He told me that laptop keyboards are replicable. Now I have got a new keyboard installed and my laptop works very smooth.

    ReplyDelete
  3. Thank you very much Steve. I still don't understand what the problem was, but I did as you said and it's work!

    ReplyDelete
  4. Steve, thank you very much for this hint. I also was searching and did not find any solution for this. Now my LG LW20 is running again ;)

    ReplyDelete
  5. Thank so much Steve! You are awesome. Works on my LG S1 express dual pro. Thanks again. :)

    ReplyDelete
  6. Wow!
    And does it work on Arch??
    thanks,

    ReplyDelete
  7. Don't know rikhard, never used Arch. It's worth a try though.

    ReplyDelete
  8. so it's a file that i should edit?
    and would korean work after this procedure?

    ReplyDelete
  9. Yes, the file is /etc/default/grub. After adding the extra options to the relevant line, run sudo update-grub to make the changes take effect. Not sure about different languages - I'd guess yes, it should work. It's worth a try, you can always change it back if it doesn't work.

    ReplyDelete
  10. This comment has been removed by the author.

    ReplyDelete
  11. Steve,
    In my case the keyboard was unresponsive during the initial Lubuntu 14.04 LTS install on an LG LM40.
    Added the parameters on the initial installation screen.
    After installation, modified /etc/default/grub and ran update-grub.
    Thank you for posting this fix. Helped me a lot.
    -Robert

    ReplyDelete
  12. Steve,

    Thanks for your blog on this topic. I actually had a different problem, but I tried your solution in my search to figure out what happened to my keyboard. I wanted to put my solution here in case someone else could benefit. Somehow I had turned on an accessibility feature called "slow keys" under the keyboard/typing settings. It gave the appearance that the keyboard wasn't working at all because I was typing at a normal speed. I turned the feature off, and all is well again! I hope this comment helps someone else.

    ReplyDelete